Welcome, Guest
Please Login or Register.    Lost Password?

My Ubuntu VHD does not boot in VMlite Workstation
(1 viewing) (1) Guest
Go to bottomPage: 12
TOPIC: My Ubuntu VHD does not boot in VMlite Workstation
#1952
My Ubuntu VHD does not boot in VMlite Workstation 9 Years, 6 Months ago Karma: 0
Hi,

I recently learned about Vboot. I think it is a great Idea. Hats off to the developers.

I run a windows 7 (32bit) OS and I used used virtual box to run ubuntu. After I realized that Virtual Box is not enough for me and I require more processing power, I tried vboot.
I have currently uninstalled virtual box completely and using VMLite workstation to run virtual OS.

Now to my questions,
I have 2 questions.
1. I run ubuntu which i downloaded here as a real appliance and it worked great, it also worked on Virtual Box. But recently, It is working only as a real appliance and not on VMlite workstation. The boot menu is different from the screen I get when i run it as a real appliance. like, i get only one option when i run it as a real appliance (Ubuntu, Linux 2.6.31-14-generic) but when I run it on VMLite workstation I get 6 different options and non of them works.
I know this is because its pointing to different grub.cfg I want to configure both grub files to open the same system.

I get the following error when I try to run on VMLite,
[IMG/]img56.imageshack.us/img56/4092/fail1.png[/IMG]

2. when I do an update to Ubuntu, it does not reflect on the grub.cfg It always opens 2.6.31-14. and the current version is 2.6.31-20

Thanks alot, I can give you additional information if you require
Merdocx
Junior Boarder
Posts: 38
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1953
Re: My Ubuntu VHD does not boot in VMlite Workstation 9 Years, 6 Months ago Karma: 52
Welcome to the forum, and I am glad that you find vboot useful.

1. When you run the Linux VHD as a vm inside vbox or VMLite, you use the vhd as an hard disk (attach the vhd to vm from VMLite Workstation), and you have to use the /boot/grub/grub.cfg configure file. the root= variable should not be something like /dev/vloop0p1, it shoulde /dev/sda1, for example.

Your screenshot indicates that you configured the root=/dev/vloop0p1, which won't work.

2, do you refer to the real appliance? or the virtual machine?

If you refer to vboot, when you recompile the kernel, you can modify the vboot grub.cfg which is on your windows NTFS drive, c:\vboot\grub\grub.cfg
admin
Moderator
Posts: 2350
graph
User Offline
Gender: Male
The administrator has disabled public write access.
 
#1954
Re: My Ubuntu VHD does not boot in VMlite Workstation 9 Years, 6 Months ago Karma: 52
if you have the original vhd file downloaded from our site, there is a .mop file that you can double click to launch the vm using VMLite Workstation.
admin
Moderator
Posts: 2350
graph
User Offline
Gender: Male
The administrator has disabled public write access.
 
#1957
Re:My Ubuntu VHD does not boot in VMlite Workstation 9 Years, 6 Months ago Karma: 0
Thanks alot for your replies.

changing from /dev/vloop0p1 to /dev/sda1 works great. for the 2nd question, I am referring to the vboot menu which pops when I start it as a real Appliance.
I tried editing the grub in C drive, but it gives me some sort of sync error. and does not boot anymore.

And I have 1 more, when I run the VHD as a VMLite VM, it lags alot. Is there a way to get around this. And also when i change the settings for the VM to enable 2 cores, it does not work.
Merdocx
Junior Boarder
Posts: 38
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#1958
Re:My Ubuntu VHD does not boot in VMlite Workstation 9 Years, 6 Months ago Karma: 52
when you use a new kernel, you may need to recompile our virtual disk driver. Since our source code is not available at the moment, so you will have to wait. We are cleaning up the code, and will release the code within next two weeks, perhaps. Once you have our source code, you compile it, then should work with your new kernel.

If you run the vhd as vm, you shouldn't change the boot menu at all, the builtin one inside /boot/grub should work.

As for performance, vm will never catch a real machine, which is why we provide another option as VBoot.

Since the vhd runs well on a real dual-core machine, I don't see any reason why it does not work as a vm for 2 cpus, did you also enable IOAPIC, etc?
admin
Moderator
Posts: 2350
graph
User Offline
Gender: Male
The administrator has disabled public write access.
 
#1963
Re:My Ubuntu VHD does not boot in VMlite Workstation 9 Years, 6 Months ago Karma: 0
Thanks for replying again.

The problem is that my ubuntu lags alot when I run it as a VM compared to my old ubuntu installation from Virtual Box. May be its because the current ubuntu installation is i686 and my other one is 32bit.

And the reason it does not run on dual core is that my machine does not support VT-X. Technically it should because Intel's website says that it does support but SONY has disabled it permanently (NO option to enable in BIOS )

Thanks alot for all your help.
Merdocx
Junior Boarder
Posts: 38
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
Go to topPage: 12